Ubuntu10.04にRuby1.9とRails3.1をインストール

手順のみメモします。

$ sudo aptitude install ruby
$ sudo aptitude install rubygems
$ sudo gem install rubygems-update
$ sudo /var/lib/gems/1.8/bin/update_rubygems
$ sudo gem install rvm
$ bash < <(curl -s -B https://rvm.beginrescueend.com/install/rvm)
$ sudo aptitude install curl
$ rvm reload
$ rvm install 1.9.2
$ vi $HOME/.bashrc

; 以下をファイル末尾に入力
if -s $HOME/.rvm/scripts/rvm ; then
source $HOME/.rvm/scripts/rvm
fi

$ source .bashrc
$ rvm 1.9.2 --default
$ sudo aptitude install zlib1g-dev
$ cd ~/.rvm/src/ruby-1.9.2-p290/ext/zlib/
$ ruby extconf.rb
$ make
$ make install
$ gem install rails
$ wget http://nodejs.org/dist/node-v0.4.12.tar.gz
$ tar zxvvf node-v0.4.12.tar.gz
$ cd node-v0.4.12/
$ ./configure
$ make
$ sudo make install

この後、一度プロジェクトを作って、そのGemfileに

gem 'execjs'
gem 'therubyracer'


を書いて後にbundle installの実行が必要でした。